Buy Now Buy Now *mycrysis-interstitial-content*
  • Author
  • Subject: MP Data Patching Issues

    This thread will be a central thread for anyone to report problems obtaining the Multiplayer Data Patch.

    I will update this first post with any relevant updates that appear throughout the thread.

    Firstly for anyone experiencing problems, and not seeing [ONLINE PATCH x] in the bottom left hand corner of the Multiplayer menus please try the following

    • Please leave the client sat in the Multiplayer menus for a few minutes, and then re-enter Multiplayer (exit to Single Player, then re-enter Multiplayer) or restart the game.
      • if the patch is being slow to download this should ensure that the game has enough time to finish downloading the patches and will then cache them. Upon re-entering MP these patches will then be used by the game
    • The following has worked to resolve this issue for someone, so may be worth trying
      • in a command prompt
      • type ipconfig /flushdns
      • wait for 30 seconds
      • type ipconfig /registerdns
    • Some people have gotten it to work by uninstalling anti-virus/firewall protection software. In these cases even though they'd disabled the software it was still causing problems with the patching that went away once the software had been uninstalled. Having to uninstall such software isn't ideal, it would be preferable if they could be configured to not interfere with the game from doing what it wants to do. So far the following software has been confirmed to cause problems
      • Blue Coat K9 Web Protection
      • F-Secure
    • As a workaround to downloading the patches in the game you can download them from the following location ... patch1.pak

      edit. this has been updated for the new Patch G

      Please save these files into the cache folder for the game, ie.

      C:\Users\<USERNAME>\Saved Games\Crysis3\cache\

      and then try running the game. These files will get out of date over time, this is not the ideal solution and it still will not allow you to play with the game properly patched if your computer is unable to talk to the server at all. However its a workaround that has seemed to help some people so its worth trying. We will try to update the list of patches available here. You will have to re-download them whenever we post new patches.

    If there is still a problem then please answer the following questions in a post on this thread

    Could anybody who is having problems getting the patch try to access this test file in a web browser on the PC in question ... t/test.txt

    It's contents should display as

    "Crysis 3 - Multiplayer Patch Test File"

    If they are unable to see this file in their browser then it shows that their PC cannot access the server for some reason. Hopefully this file would then be an easier thing for them to test against whilst they are trying to debug any problems with their network connection.

    If they can see the file in their browser then it should prove that their PC as a whole isn't restricted access to that server by proxies or routers in between the two.

    However if they are still unable to get their Multiplayer updated, then it would suggest that something is different between their browser and their copy of Crysis 3, ie. perhaps a software firewall is blocking some traffic for Crysis 3?

    Finally an overview of how the patching system actually works

    When the game enters Multiplayer, it asks the server (on port 80) what patches are available. The list of available patches are returned and the game proceeds to then download each available patch. As each patch is downloaded, they are cached to your hard disk in the location described above, so that you won't have to download that patch again. Crucially only the patches that are reported by the server as being available will be used by the game.

    If anyone else who is having problems getting the patch applied could look in the cache location

    ie. C:\Users\<USERNAME>\Saved Games\Crysis3\cache\...

    I imagine most people will not have the patch cached as they've never been able to contact the server for some reason.

    22 Feb 2013, 17:13
  • Subject: Re: MP Data Patching Issues

    YESYESYES! i have fix the problem!!! What i did was open up my CMD and type in ipconfig /flushdns then i waited 30sec then i typed in ipconfig /registerdns. When i logged in BAM it was updated :D!
    22 Feb 2013, 18:19
  • Subject: Re: MP Data Patching Issues

    DevonX, did you possibly VPN somewhere to get slightly earlier than normal access to the game for your territory? Wondering if that might have something to do with the issue. Nothing bad will happen if you say 'yes' :P
    22 Feb 2013, 18:23
  • Subject: Re: MP Data Patching Issues

    Fellblade, we VPN to Russia because we had a russian key which has been changed to a total fresh English install by origin. Still can't see servers and don't have the PatchA.
    Do you think that russian proxy that has been deleted, could have effected this even though that this is a fresh install?
    22 Feb 2013, 18:30
  • Subject: Re: MP Data Patching Issues

    It your DNS cache could potentially be polluted. I'd suggest following the same steps as DevonX and seeing if it fixes the problem
    22 Feb 2013, 18:33
  • Subject: Re: MP Data Patching Issues

    Flushdns worked but registerdns said 'The requested operation requires elevation' and logging into the game still showed no update.
    22 Feb 2013, 18:36
  • Subject: Re: MP Data Patching Issues

    @DevonX - I'm glad that you've able to get the patch. I've put your fixes into the first post. Hopefully that will be the end of the issue for you
    @perilousmutant - a quick google to that error message seems to suggest that you may not have admin rights to perform that operation? I'll presume you've rebooted the PC. Not sure if the DNS settings survive a reboot or not.
    22 Feb 2013, 18:41
  • Subject: Re: MP Data Patching Issues

    I ran cmd as admin and registerdns said 'registration of the dns resource records for all adapters of this computer has been initiated. Any errors will be reported in event viewer in 15 mins.'
    Still no luck.
    22 Feb 2013, 18:55
  • 22 Feb 2013, 19:14
  • 22 Feb 2013, 19:16

ESRB Video Game Rating

This title is rated Mature for:

  • Blood
  • Partial Nudity
  • Strong Langague
  • Violence